You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
I would be fine with separating it into two hints, although in any case it doesn't affect my coding as I'm not concerned with checkstyle.
Just personally, I'd much rather have code written so that this. is never used. The only time I see it in use, is prefixing a class field with this and being assigned in a setter method or constructor by a parameter named the same thing. In my case, I've always refactor-renamed the parameter to one or two letters and removed the "this." prefix. I don't think methods need the "this." prefix.
Some coding-guidelines suggest that you prefix fields with this. but not methods (at least in Java)
http://checkstyle.sourceforge.net/config_coding.html#RequireThis
The text was updated successfully, but these errors were encountered: