You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
After some literature review, I believe the current naming convention for complex methods in xeofs (e.g., ComplexEOF, ComplexMCA etc.) is somewhat misleading. While there isn't a universally fixed naming standard, most textbooks I've consulted use the following convention:
Complex Model: The input is a naturally complexified field, such as the $u$ and $v$ wind components combined into $z=u+iv$.
Hilbert Model: The input is a real field that is complexified using the Hilbert transform.
Both models explore amplitude-phase relationships, but the difference lies in the input type. In xeofs, the methods currently labeled as "Complex" actually correspond to what are generally called "Hilbert Models." As a side note, xeofs can handle true complex models with the standard EOF class, but it lacks the functionality to easily access the amplitude and phase of components/scores.
I think xeofs would benefit from adopting this more commonly used naming convention. This would involve renaming all ComplexModel classes to HilbertModel and creating a new ComplexModel class that inherits from EOF and includes methods for amplitude and phase.
Although this is a small change, it would be a breaking one. We might consider bundling it with other potential breaking changes (#187 and #183) for a xeofs v3 release.
The text was updated successfully, but these errors were encountered:
After some literature review, I believe the current naming convention for complex methods in xeofs (e.g.,
ComplexEOF
,ComplexMCA
etc.) is somewhat misleading. While there isn't a universally fixed naming standard, most textbooks I've consulted use the following convention:Both models explore amplitude-phase relationships, but the difference lies in the input type. In xeofs, the methods currently labeled as "Complex" actually correspond to what are generally called "Hilbert Models." As a side note, xeofs can handle true complex models with the standard EOF class, but it lacks the functionality to easily access the amplitude and phase of components/scores.
I think xeofs would benefit from adopting this more commonly used naming convention. This would involve renaming all
ComplexModel
classes toHilbertModel
and creating a newComplexModel
class that inherits fromEOF
and includes methods for amplitude and phase.Although this is a small change, it would be a breaking one. We might consider bundling it with other potential breaking changes (#187 and #183) for a xeofs v3 release.
The text was updated successfully, but these errors were encountered: