Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SCP-2441: Implement new welcome screen design. #3453

Merged
merged 5 commits into from
Jun 29, 2021

Conversation

merivale
Copy link
Contributor

Does what it says on the tin. Looks like the screenshots below. The "Choose wallet or paste key" input doesn't match the designs yet, but I'll do that in another PR - it will require changing the InputField, so I'll need to make sure it doesn't break the other inputs. Also I might implement the new ChoiceFormat metadata at the same time.

localhost
localhost_2
localhost_3
localhost_4
localhost_5
localhost_6
localhost_7

@merivale merivale requested a review from hrajchert June 29, 2021 10:18
Copy link
Contributor

@hrajchert hrajchert left a comment

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

brent_rambo

Comment on lines +35 to +36
_welcomeState :: Traversal' State Welcome.State
_welcomeState = _subState <<< _Left
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I like this renaming :)

Maybe it make sense to rename _playState into _runState in a following PR 🤔

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Yes, I've already made a start on precisely that. I was thinking of _dashboardState, and of combining it with the ContractHome stuff. Because the new designs explicitly call that screen the "dashboard", and because contacts and contract setup stuff will be on a modal instead of in their own screen.

We could go with _runState instead... 🤔 What's your preference? I think I've a slight preference for "dashboard", because the whole thing is now being called "run" (and at some point we should rename the directory), so we would effectively have Run = Welcome | Dashboard.

Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Mmhmhm, I like both options instead of play. My only concern there is that Dashboard would be what is currently the ContractHome, but there are other screens inside that state.

Copy link
Contributor Author

@merivale merivale Jun 29, 2021

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Yes, but there won't be other screens there after the next redesign.* That's why I said that contacts and contract setup stuff will be in the new sidebar modal thing in my previous comment (and not in separate screens, as now) - but I didn't explain what the thinking was there, sorry.

* There will be a screen for each contract inside the dashboard, but that feels right to me. The breadcrumb will be "Dashboard > My contract name".


handleAction (WalletNicknameInputAction inputFieldAction) = toWalletNicknameInput $ InputField.handleAction inputFieldAction

handleAction (WalletIdInputAction inputFieldAction) = toWalletIdInput $ InputField.handleAction inputFieldAction

handleAction (PickupWallet walletNickname) = do
assign _pickingUp true
handleAction (ConnectWallet walletNickname) = do
Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I was a little disorianted with _connecting until I saw this. Why ConnectWallet and not UseWallet? What are we connecting?

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Yeah, it probably should be UseWallet. It's because before we had "Pickup" on the button and a "pickingUp" flag in the state, and "Picking up..." on the button when pickingUp == true. But "using" in that case doesn't make sense. Anyway, I'll try and think of something better and push it shortly.

@merivale merivale merged commit 5e93bfd into master Jun 29, 2021
@merivale merivale deleted the merivale/new-welcome-screen branch June 29, 2021 15:57
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

2 participants