-
Notifications
You must be signed in to change notification settings - Fork 172
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Split fuel/charge port location signal #614
Conversation
Meeting 05/23
|
This is the values defined in https://android.googlesource.com/platform/hardware/interfaces/+/master/automotive/vehicle/2.0/types.hal#3537.
No further definitions, but a possible interpretation is:
So In COVESA VSS we (since before) also have a "middle alternative". Which maybe could be useful for mini-buses, where you maybe have the fuel-port/charge-port behind driver seat, but in front of last passenger row. I think the first question we must agree on is how many alternatives we need for each side. Do we need 2 or 3 alternatives for left and right? (front+rear(+middle)). For front and rear - is one alternative sufficient? |
I tried a picture for a "consistent" way of all possible locations to help me. Pattern is: Side first, then position on that side. The ones in brackets I have never seen, but may be useful for consistency purposes Might be argued whether Another related questions: Should we support multiple charge ports like this BYD https://carnewschina.com/2023/03/14/byd-denza-doubles-up-on-charging-power/ |
The signals could easily be of |
"Left field" idea. Has it been considered to use an instance for the location? That is, not defining a separate signal but instead adding instances to Fuel Port and Charge Port. This would support multiple ports in one vehicle, with the instance defining the location (similar to rows and positions for seats). |
@ppb2020 like the idea, as for example the ports may have different capabilities (i.e. the text in the BYD example seems to hint at AC only being available on one side). |
We have in Charging.ChargePlugType the possibility to mention multiple plug types, but all of our other signals like Charging.ChargePortFlap seems to be based on an assumption that there is only on flap, or at least that you can only connect one charger at a time, and it isn't that important knowing which plug or connector that is used. Having an instance-branch with possibly 9 positions as in the picture from Sebastian would work, and then for each of them showing which connectors that exists there (one or many), possibly something like below. But then the question is - shall we also include separate signals for example for Charging.ChargePortFlap for each instance, and if so also keep the "global" Charging.ChargePortFlap signal? I.e. so you can have one signal that indicates "True" if any flap is open, and then individual signals to find out exactly which flaps that are open.
An alternative solution that we have used now and then instead of instances is to use two signals with arrays, and say that the relative positions matter. Like if we keep Charging.ChargePlugType as is and introduce a new signal which states position for each plug type included in the other signal. |
7961c51
to
204b1c9
Compare
Refactored PR based on comment. For now using two arrays with "soft" dependency by relative indexing. But having instances would work as well - as long as we design it so it cover the case where one location might have multiple plugs/ports. Using struct would be a different alternative but require even more discussion. |
775f69e
to
4f20d42
Compare
Please review |
Could we take this opportunity to harmonise and correct our terminology? Specifically, the term "plug" is currently used here, however, a plug is part of a cable that connects to a port. EVs therefore have ports not plugs (unless anyone knows of an EV that has a cable permanently attached?). We should also use this term when talking about refuelling position too, just to be consistent. Therefore, I propose the following changes for consistency and correctness:
In the next major version of VSS, we may also want to rename "ChargePlugType" to "ChargePortType", but not in 4.1 as that would be a backwards incompatible change. Or can we flag it here in 4.1 that we intend to rename it in 5.0 e.g. in the Deprecated field? |
I have no objection referring to port rather than plug. Did you had time to discuss it on the meeting yesterday or it something that we better shall discuss next week? Concerning name changes - for existing signals, if we assume that next release will be VSS 4.1 the historical approach is to copy the old signal and change name on the copy. Then for now keep the old signal but add "deprecation: V4.1 renamed to Vehicle.XXX.YYY". that way both will exist in VSS 4.1 (and VSS 4.2 if it will exist), but the old name will be removed in VSS 5.0 |
Meeting notes:
|
928ab77
to
f4780d9
Compare
Please can we rename the new instance of RefuelPosition to RefuelPortPosition? This not only provides consistency within VSS (i.e. with ChargePortPosition) but also better separates the new definition from the old (which will be deprecated at the next major release). I also proposed renaming IsFuelDoorOpen to IsFuelPortFlapOpen, in order to align with ChargePortFlap. Can this be included in this PR, or should it be in a separate PR? |
I think it better could ve done in this one. I will update the PR |
f4780d9
to
260a66a
Compare
Thanks, the changes look good to me now. |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
In order to spice it up a bit. What if we have inductive charging. :) https://t.ly/A6nZ
Looks good to me.
I would be happy for a PR addressing inductive charging. But I know too little about it to be able to provide something useful. I do not even know if you (as owner) need to know where the inductive charging point is on your vehicle so that you can park the car as needed for charging to start |
@@ -277,7 +277,8 @@ Charging.ChargePortFlap: | |||
datatype: string | |||
type: actuator | |||
allowed: ['OPEN', 'CLOSED'] |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Meeting notes: Create new boolean signal and mark this one as deprecated
Meeting notes:
|
Signed-off-by: Erik Jaegervall <erik.jaegervall@se.bosch.com>
260a66a
to
83ee502
Compare
@erikbosch Looks good to me now, thanks for your hard work making everything align. |
Sounds good to me. |
This tries to refactor VSS to be more aligned with Android VHAL.
In VHAL three signals exist:
In VSS so far we had a joint signal for fuel door and charge port, but that does not work well for hybrids. We also lacked some positions like front/rear, so I added them. I kept the "middle" positions, but do not really know how useful they are.