Skip to content

Commit

Permalink
[SPARK-6118] making package name of deploy.worker.CommandUtils and de…
Browse files Browse the repository at this point in the history
…ploy.CommandUtilsSuite consistent

https://issues.apache.org/jira/browse/SPARK-6118

I found that the object CommandUtils is placed under deploy.worker package, while CommandUtilsSuite is  under deploy

Conventionally, we put the implementation and unit test class under the same package

here, to minimize the change, I move CommandUtilsSuite to worker package,

**However, CommandUtils seems to contain some general methods (though only used by worker.* classes currently**,  we may also consider to replace CommonUtils

Author: CodingCat <zhunansjtu@gmail.com>

Closes apache#4856 from CodingCat/SPARK-6118 and squashes the following commits:

cb93700 [CodingCat] making package name consistent
  • Loading branch information
CodingCat authored and srowen committed Mar 3, 2015
1 parent 0c9a8ea commit 975643c
Showing 1 changed file with 2 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -15,11 +15,10 @@
* limitations under the License.
*/

package org.apache.spark.deploy
package org.apache.spark.deploy.worker

import org.apache.spark.deploy.worker.CommandUtils
import org.apache.spark.deploy.Command
import org.apache.spark.util.Utils

import org.scalatest.{FunSuite, Matchers}

class CommandUtilsSuite extends FunSuite with Matchers {

0 comments on commit 975643c

Please sign in to comment.