-
Notifications
You must be signed in to change notification settings - Fork 427
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Rename _separate to forward_wav #337
Conversation
asteroid/models/base_models.py
Outdated
if is_overridden("_separate", self, parent=BaseModel): | ||
return self._separate(wav, *args, **kwargs) | ||
return self(wav, *args, **kwargs) |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Ok, maybe the is_overriden
is completely overkill..
Removing _separate
from the base class and hasattr(self,"_separate")
+ raise warning if it does would have been enough.
Hahah, I happy to write that function anyway 😅
This is ready IMO. |
See comments, otherwise LGTM |
/rebase |
Co-authored-by: Jonas Haag <jonas@lophus.org>
Proposition: rename
_separate
toforward_wav
inBaseModel
.This is something that was a bit discussed in #305 : asking users to overwrite a private method doesn't feel right. This fixes it.
Possibly in conflict with #305