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Preface

I have been shooting Canon EOS digital cameras for fifteen years now. I wanted to re-
motely control my EOS D60 since day one, but digital camera technology was not
there in 2002. Six additional years had to pass until the first Canons ready for serious
tethered operation arrived (the 50D and the 5D Mark II). Needless to say, I immedi-
ately started growing plans about an easy-to-use, high performance tethering app.

In one of the long nights of the Norwegian winter of 2011, I shared these plans with
two friends whom I was shooting with. The result was Kuuvik Digital, a company we
founded together to realize this dream. The company delivered Kuuvik Capture in
2013, plus a few updates during that year and the next. But problems started to surface.
Issues with Canon’s mediocre and unsupported Software Development Kit. Obstacles
that couldn’t be resolved in traditional venture capital realms.

So I acquired Kuuvik Capture in the beginning of 2015 (I wrote the app originally, but
the actual rights belonged to Kuuvik Digital), with a firm intention to reboot it based
on my recently developed Digital Camera Library. With no financial pressure from any
investors.

Boy, what followed was the biggest turmoil of my entire life. I had to climb a few enor-
mous “technology mountains”. I rewrote half of the application - from camera com-
munication through RAW decoding to image display - to bring Kuuvik Capture to the
level of reliability and speed I was after. And I'm extremely proud of the results.

On the pages of this book I would like to invite you to a journey through the app. I bet
I will be able to show you some pretty neat stuff. Some of them is a world’s first!

There’s only one person I would like to thank for her endurance during the stormy
months of the creation of the second Kuuvik Capture: my love and my partner, Agnes
Lorincz. Thank you for staying with me!

I hope you will enjoy Kuuvik Capture — and this book.

Laszlo Pusztai
March 2017.
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What is Kuuvik Capture?

Kuuvik Capture 1s an app for remotely controlling your Canon EOS digital camera,
which is also known as fethering. The name comes from the cable connecting the cam-
era to the computer, and 1s used even when no cable is involved (wireless tethering).

But why would anyone want to do it?

I guess the benefits of working on a larger
screen are obvious. As well as the benefits
coming from the ability to place the camera
in hard-to-reach places and still stay in con-
trol with no need to balance on high ladders
or crawl into tight corners.

A friend uses it for architecture to check
with the guidelines that everything is lined
up correctly, and to automate brackets. Lug-
ging around a notebook is even a plus for
him, since this way he can deliver finished
images right at the client’s site.

We have a few customers doing photomi-
crography with it (that is, using a micro-
scope as a taking lens on the camera).

I use Kuuvik Capture for landscape and
product photography (my field “studio” is
on the picture) because checking sharpness
and focus 1s much easier with its sharpening
and peaking tools, and to help me assess the
composition. And I notice distractions on
the large screen that I tend to miss on the camera’s smallish LCD. Not to mention how
much faster 1s to focus a super telephoto lens when it’s used for astrophotography with-
out touching the lens and thus avoiding vibrations.

As you can see, the concept is rather simple, but uses are limitless.

The number one goal behind the app is to help you produce the highest quality images,
and thus it works predominantly with RAW files (although you can also shoot RAW +
JPG or plain JPQG). It’s important to note that Kuuvik Capture is not a RAW converter,
though - you’ll need to pair it with your regular RAW conversion app (Lightroom or
Capture One for example). It decodes the RAW files only for displaying the histogram
and clipping warnings.



Kuuvik Capture also supports movie recording.

The app is designed for the working photographer, and we continuously receive re-
quests from our customers to make some aspects of their work faster and easier. We
take these very seriously, and most of them made their way into the app.



Connecting the Camera

You can connect the camera with your Mac via USB cable, or via some kind of net-
work (wired Ethernet or Wi-Fi) in case the camera supports it. Since this is a basic re-
quirement to use the app, let’s discuss it before everything else.

I don’t want to repeat here what’s already written in the camera’s user manual. If you
haven’t done so already, it’s a great time to read through the respective chapters.

USB

The USB connection seems pretty easy (just plug in the cable at both ends), but there
are a few gotchas we learned through the years. The first is cable quality. You need a
high quality cable, especially if it’s long. I personally use either the cable that came with
the camera or TetherTools’ 15 feet high visibility orange cables. A bad cable causes con-
nection drops and erratic behavior - so if you encounter strange things the very first
thing to blame 1s the “tether” itself.

Second is that the built-in Wi-Fi (as well as the W-E1 adapter) blocks the USB port.
You must disable Wi-Fi (turning it off 1s not enough) and remove the W-E1 card before
trying to use the USB connection.

And then there’s the Photos app in macOS that starts every

time you connect the camera. It’s a pain in the back to close
it every time. You can’t leave it open, as it will interfere with
Kuuvik Capture’s camera communication.

@ Canon EOS 7D Mark [l

L0

You can control which application opens when you connect
a camera in the Image Capture app. Yes, you read that right.
Not in Photos, not in System Preferences, but in Image Cap-
ture. So to get rid of the Photos autostart go into Image
Capture, connect your camera, and click its name under De-
vices.

Then click the little triangle in the bottom left corner to re-
veal the popup list where you can choose what to do when
this camera is connected (to set Kuuvik Capture as the app
to open, click Other... in the list and pick the app from the
Applications folder).

Ceonnecting this camera opens:

&

&Y Kuuvik Capture.app

There’s another, more brutal way to get rid of this annoy-
ance, and this will even prevent Photos from starting when a
memory card reader is connected.

Delete after import

=



Open the Terminal app and copy & paste the following command on macOS 10.11 and
later:

defaults -currentHost write com.apple.ImageCapture disableHotPlug -bool YES
And the following two on macOS 10.10:

defaults -currentHost write com.apple.ImageCapture2 HotPlugActionPath
-string ""

defaults -currentHost write com.apple.ImageCapture2 LastHotPlugActionPath
-string ""

Don’t forget to press Enter after each command.

We have recently discovered another impostor that may inadvertently connect to your
camera and cause trouble: Dropbox. Even when its auto uploader functionality is off,
the Dropbox app sitting on your menu bar grabs all the cameras connected to your
Mac. We’ve reported this to Dropbox, and hope it will be fixed sometime. But if you
get the Another app is also using the camera error with seemingly no app open, then my
first recommendation would be to quit Dropbox. Well, this may apply to other cloud
storage apps that work with cameras, too.

macOS Catalina 10.15.2 and later users must allow both Photos and Removable Vol-
umes access. macOS will not let the app to communicate with USB connected cameras
otherwise. In case you missed to enable these when prompted, 4.5 and later versions of
the app will warn you to go to System Preferences > Security & Privacy, and on the Privacy
tab enable these permissions. Photos 1s under Photos, but you'll find Removable Volumes
under Files and Folders.

Wi-Fi and Ethernet

You’ll need either a Wi-Fi equipped camera, a built-in Ethernet socket or a separate
Wireless File Transmitter for this to work. Only Canon’s transmitters are supported,
third party Wi-Fi remote control boxes will not work. Please check the tech specs
(https://www.kuuvikcapture.com/tech-specs/) for the full list of compatible equip-
ment.

Canon cameras provide network connectivity in several ways. The most complete is the
EOS Utility connection mode. For this mode a camera needs to be paired to a given app
on a given computer. Using two apps on the same computer? You need to pair the cam-
era to them separately, and only one can be active at a time.


https://www.kuuvikcapture.com/tech-specs/

File Camera Image The computer side of this pairing process

About Kuuvik Capture 1s dramatically simplified with Kuuvik
AERnONEigmeNs ._ Capture compared to Canon’s own EOS
Preferences... Utility.

Wi-Fi and Ethernet Pairing...

The app needs to be in “pairing mode” to
accept a pairing request coming from the
camera. This mode is accessible through
the Kuuvik Capture > Wi-Fi and Ether-
net Pairing... menu item (or by pressing

Services

Hide Kuuvik Capture
Hide Others

Quit Kuuvik Capture

Kuuvik Capture displays the pairing win-
dow (shown on the next page) while in
pairing mode. This window also shows
your computer’s name, which will appear
on the camera’s LCD during the last pairing step, so you can double-check that you are
pairing to the computer you were intended to.

And that’s all you need to do on K
: I 1 0 Wi-Fi and Ethernet Pairing

the Mac.

. ) 7, Discoverable as "triton".
Once in discoverable state, you ne
can start the configuration process
on your camera. The process con-

sists of three large steps:

Please start the pairing process on your camera now
in “EOQS Utility” connection mode.

1. Choose a connection mode.
2. Configure your network.
3. Do the actual pairing.

They are documented in your camera’s or wireless transmitter’s user manual (which
you may want to have at hand now), but there are a few important points to consider.

First, do not start any Canon app that may be mentioned in the manual. You are now
pairing directly to Kuuvik Capture, and not to Canon’s apps. The camera will think it’s
talking to EOS Utility during the whole process. It is highly recommended to quit
Canon’s apps as they will almost certainly interfere with Kuuvik Capture.

For step 1, you must use the Connection Wizard on cameras where it’s available (e.g. 5-
series, 7-series with the external brick), otherwise you won’t be able to complete step 3.
Choose the Remote Control (EOS Utility) or EOS Utility mode (depending on what
camera model you have) in the Connection Wizard.



In step 2, the camera will ask for network specific parameters (whether it’s wired or
wireless, plus various options and a password specific to your network). This is the
most complicated part of the entire process, but Wi-Fi setup is such a thing... I'd rec-
ommend to study the camera/transmitter manual beforehand.

The last step is the actual pairing. The camera’s LCD in-
structs to start EOS Utility, but we’re pairing to Kuuvik

EOS 237221 paiing (coneection) Capture, so put Kuuvik Capture into pairing mode if it’s
with the computer in progress.

Start EOS Utility on the not there already.
computer.

| It may take up to 1.5 minutes for the camera and your
R .l Mac to find each other.

This 1s how the camera’s LCD will look when the con-

nection is established.
PC triton
Pairing should be done once (unless in the meantime you Lol
paired your camera to another app, another computer, or
used another network). To deal with these different sce-
narios, the very last screen in the process (after clicking L cancel __ok ]
that OK button) lets you save up to a few setups into

your camera’s memory.

Connect to the PC.

But if nothing has changed, Kuuvik Capture will find your camera automatically the
next time you turn it on and connect to the network, so the pairing is not necessary ev-
ery time you want to use a Wi-F1 or Ethernet connection.

Once pairing succeeds the camera’s LCD will turn black, the pairing window will dis-
appear, and the camera’s name will show up in Kuuvik Capture’s camera selector.

Notes on Wi-Fi Speed

It seems that Canon implements one of the lowest speed classes for each of their Wi-Fi
transmitters. This is 150mbps for the external 802.11n bricks (using only one spatial
stream), and a shockingly low 60mbps for the internal transmitters (despite they adver-
tise it as 150). So don’t expect miracles and be prepared for 12-15 second downloads on
these slower cameras. On the other hand, the external bricks are fast enough to be per-
fectly usable when the network signal 1s good.

Wi-F1 networks can become unbelievably slow (think longer distances and/or interfer-
ence), causing the camera to disappear from Kuuvik Capture. A longer network time-
out (a longer time allowance for intermittent network errors to clear) may solve this, but
at the expense of delaying the detection of actual issues (such as when the battery dies).
The app has a preference to control this timeout, and it will be discussed together with
other preferences.



Multiple Cameras

You can connect multiple cameras to Kuuvik Capture, re- S EEEOET

gardless of their connection type (USB or Wi-F1 or Ether- e

net), but only one of them can be active at a time. Use the

camera selector in the top right corner of the app’s window to switch between them.

The active camera is what you operate. Non-active cameras are locked (and thus can-
not be operated).



The Main Window

Kuuvik Capture’s main window is divided into four regions.
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1. Image Area. This is where your images are displayed. This includes live view,
multi-point live view as well as the currently selected image in the Image
Browser.

2. Toolbar. This is the home for the tools you can use to work on the image area.
Green 1cons mark an active tool, gray icons are disabled tools. There are three
vertical dots next to some of the toolbar icons. Click them to revel a toolbar op-
tion panel. These option panels can be used to configure the given tool. If you
open an option panel, and there’s not enough space for it on the toolbar, the last
recently used one will be closed. Only one option panel will ever be open when
Solo Mode (right-click the toolbar for it) 1s active.

3. Sidebar. The place for camera-related controls, dealing with everything from ex-
posure settings through image navigation to the Dual Histogram. At the top is the
camera selector and battery information. Sidebar sections can be opened and
close by clicking their title. Some of the sections can be turned of and off with a
switch on the right side. A section is on when the switch is green.

4. Image Browser. As the name implies, it’s the place for the images captured with
the app. You can do rating and labeling here. Plus select the image that’s dis-
played in the Image Area. These images are stored in a session, a construct I'll
cover in Chapter II.



And of course there’s the app’s menu. When I begin exploring a new app, I start with
the menu - and highly recommend you this practice. Going through the menu you’ll see
the various commands and functions as well as their associated keyboard shortcuts.

In Kuuvik Capture we tried to assign a keyboard shortcut to almost all commands (ex-
cept some rarely used ones). By browsing through you’ll also learn about these short-
cuts.

There’s one thing I should mention here, though. By using the Tab key, you can go
through all the controls in the main window (in case Full Keyboard Access is enabled in
System Preferences). The active control is highlighted with a green rectangle.

If a control 1s a popup list, you can browse through its elements by the up/down and
left/right cursor keys. In case the control is an exposure parameter (shutter speed for
example), then the cursor keys will select the next half or third stop element (based on
your camera’s setting), while holding down the Shift key will select the next element at
a full stop distance.

What'’s displayed in the image area changes as you work. The possible contents are the
following:

A live video stream from the camera when live view is active.

« Two or three magnified segments of the live video stream when multi-point live
view 1s engaged.

« The image selected in the image browser. In case of RAW files, this i1sn’t the fi-
nal rendering of your RAW file, just the embedded JPG preview.

» A progress indicator when an exposure sequence 1s running.

«  Empty space, when for example you just deleted an image or disengaged live
view in movie mode.

I’1l discuss basic operations on the image area (such as scrolling and zooming) together
with the corresponding tool.

Note: From this point on, I recommend to connect a camera and try everything as I proceed
with the discussion. It’s much easier to understand the app in a step-by-step manner than try-
ing to remember everything.



The Toolbar

Let’s go through the toolbar first, as it covers a large share of the app’s functionality. Af-
ter each button’s name the corresponding keyboard shortcut is in parentheses. All of
the toolbar’s functions are also available via the menu.

Live View (L)

a This button toggles live view on and off. The general concept in Kuuvik Cap-
ture 1s to start working in live view (using the app as a remote viewfinder), so
you spend a lot of time with live view on.

It takes a second or so until the live image stream appears in the app.

Live view isn’t started automatically on mirrorless cameras, such as the EOS R or M50. You
have to turn it on manually.

There are a few things you should know about live view. The frame rate is 12.5 frames
per second - some camera can’t even do this, in those cases we lower the rate. The low-
est is 7 fps. Just a few could do better, but processing higher frame rates would consume
more energy on the Mac (thus shortening its battery life), so we chose 12.5 fps even in
those cases as a good balance between power consumption and frame rate.

Live view is low resolution - 960x640 pixels or something like that (higher on some
cameras, and lower on others). So don’t be surprised if it looks blurry on your 30” dis-
play. But since this blurriness affects both the sharpening and focus peaking tools,
there’s a workaround. You can instruct Kuuvik Capture to not enlarge live view (via
View > Don’t Enlarge Live View in the menu). This way the live view stream will be
displayed as a smaller frame inside the image area, in its original resolution. Of course
it will be shrunk if the image area 1s smaller than the actual live view stream’s dimen-
s10ons.

There’s a noticeable lag in the displayed video, caused by the camera’s electronics and
encoding, the transmission and the decoding on the Mac.

Live view can also be engaged from the camera, by pressing its live view button.

Two-way operation is an important concept in Kuuvik Capture - if you do something on the
camera, the app will reflect the change.

To save battery on the camera, you can opt for disabling the its LCD during live view
(when its turned on from the computer) in Preferences. But note that camera controls
only work during live view if the LCD is on. If you need a control in this case, simply
press the live view button on the camera, and controls will be unlocked.
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Once live view is running, the app’s main window will look like the one on the follow-
ing image.
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You see two notable things here. The Point of Operation indicator frame (1). In Canon
cameras this is a special point to specify three things:

« The point of exposure metering in live view.
» Center point for zooming operations.
« Auto focusing is performed at this point.

You can turn the indicator frame off and back on with the View > Show > Point of
Operation menu item (or by pressing ~380).

The Point of Operation can be moved around with the cursor keys when the full live view
image 1s displayed (that is, not zoomed 1n, a.k.a. the Fit zoom level). Pressing Shift will
move it in larger steps. Alternatively, clicking the live image with the Pan tool active
(hand icon), it will immediately place the Point of Operation to the clicked point. More
about the Pan tool later.

Well, there are certain limits where the Point of Operation can be placed. When you have an
auto focus capable lens attached in AF mode, then you can’t go out to the edges, for example.
In MF mode though, more of the image is accessible.



Speaking of zooming, the + and - keys are used to jump between the camera’s zoom
levels (Fit/5x/10x or Fit/6x/16x in case of the 5DS/R). Once zoomed in, the cursor
keys can still be used to move around (Shift increases the step size here too).

There is also a special trackpad gesture controlling zooming: a flick-pinch. This 1s simi-
lar to the regular pinch gesture used in zooming in a multitude of apps, you just have to
do the pinching faster. The zooming will happen at the point where the cursor is lo-
cated on the image just before you started the gesture.

The other notable thing on the previous image is the Navi- UG
gator (2). During live view, it is continuously update at 1/3
of the frame rate of the live image stream.

When you zoom in, the label PAUSED and the current
zoom level will appear below the Navigator’s image. The
red rectangle, indicating the current position will also
shrink based on the current zoom level. Dragging this red
frame around, or simply clicking the image will move the
zoomed region to the clicked position.

The three buttons, with Fit, 5x and 10x labels can also be used to immediately switch to
that zoom level. Note that on the 5DS/R the zoomed-in levels are 6x and 16x magnifi-
cation.

There’s an ugly thing with the 10x/ 16x zoom level: this is a digital zoom, so you will get no
more detail than in 5x/6x. This is how zooming on Canon cameras work.

When you have a lens with a built-in focus motor attached, you can drive focus with
the keyboard. Pressing 88 T will move the focus away from the camera, and 881 will
pull it closer. Also holding the Shift key down moves the focus in larger steps.

By now you may have noticed a pattern: anything you do, holding Shift down instructs Kuu-
vik Capture to do it in larger steps.

If you want to use the mouse wheel (and the corresponding scroll gesture on the track-
pad) for focus pulling, you can set it up in Preferences. More on this when I discuss the
Preferences window.



Going back to the toolbar, click the three dots right to the live view toolbar icon (or
press *L) to reveal the Live View Options panel.

Option panels provide a means for setting parameters for the given tool. In case of live
view, you have the following:

e Style for choosing the picture style.
WB for choosing the white balance.
« A white balance picker icon.

Both the style and the WB list reflect the camera’s available picture styles and white bal-
ances. You may have noticed, that there’s no picture style of Kelvin based white bal-
ance editing facility. This is for a good reason.

It’s not a goal for Kuuvik Capture to blindly replicate everything you can set on the camera al-
ready. The app aims to provide tools that either a) can’t be found, or cumbersome to use on the
camera or b) needed for some real photography situation. Also, since shooting RAW is pre-
ferred, there’s no point in adding JPG-only tools. So that’s why there’s no picture style editor
here. If you feel that some of those are crucial for you work, contact us, and explain why you
need it.

/ The white balance picker (B key) on the live view options panel can be used to
set you custom white balance - from a gray card for example. Once you click
the live image, the picked white balance will be programmed into the Manual
white balance of your camera (overwriting what you had there), and WB is au-
tomatically switched over to Manual.

Depth of Field Preview (D)

With this button you can turn depth of field preview on and off. Unlike the
camera’s DoF preview button (which engages DoF preview while it’s pressed),
this one turns on DoF preview with one press, and it remains on until turned
off with another press.

),
(&

Another difference is while you press the DoF preview button on the camera, you’ll un-
able to operate it from Kuuvik Capture. But if you activate DoF preview from within
the app, everything will work as expected.

DoF preview is automatically turned off when you exit live view, or when you take an
exposure. The app remembers whether you had DoF preview on when exiting live
view, and automatically turns it on the next time you start live view.



The DoF preview button is disabled when shooting movies, because activating movie
mode automatically stops the lens down to the taking aperture.

Set Markers (X)

Let me break the left-to-right order of discussing toolbar icons, and bring the Set
Markers tool forward, as you need to know about it before discussing multi-
point live view.

With this tool you can place up to three markers on the screen, indicated by red, green
and blue dots (in this order). Think about markers as points of interests, points where
you need to check sharpness, focus, whatever. Markers grew out from my endless frus-
tration with the “zoom in to check, zoom out, scroll to another place with the joystick,
zoom in, check, zoom out, scroll to...” nonsense. Especially with manual lenses (which
represent 90% of my work) checking multiple points on the image 1s a tedious job.

With the Set Markers tool active, click the image to
place a marker. Command-click an existing marker
to remove it. Or press *8X (Tools > Clear Markers
in the menu) to clear all of them.

Once the markers are placed, press the . and , keys
to switch between them. When you switch to a
marker, live view jumps to 5x/6x magnification and
on the preview zoom is set to 50%. Switching be-
tween markers works even when the Set Markers tool
1S not active - you just need it for placing the markers.




Multi-Point Live View (V)

BB With multi-point live view you can see two or three different points of your
. composition in 5x magnified, semi-live fashion. I said semi-live, since the re-
fresh rate is about 1/3 of a second per point (so about a second to refresh 3

points, and also varies by camera). But this frame rate is good enough to be us-
able.

You need to be in live view and have to place at least two markers to be able to activate
multi-point live view,
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Imagine for example that you are doing product photography with a tilt/shift lens (or a
technical camera like the Cambo Actus or Arca-Swiss F-Universalis). Placing the plane
of focus in a situation like this is an iterative process, where you repeatedly check the
same points for focus. With multi-point live view you can define the desired focus plane
with three markers, and check those simultaneously.

This is one of the unique, world’s first features of Kuuvik Capture.

Multi-point live view works with select cameras, check the tech specs page
(https://www.kuuvikcapture.com/tech-specs/) for compatibility information.



https://www.kuuvikcapture.com/tech-specs/

Auto Focus (F)

F|:_ The AF tool can be used to initiate focusing using the camera’s auto focusing.

' Kuuvik Capture relies on the camera to execute the focusing operation. When
the tool 1is active, clicking the live image will place the point of operation to the
clicked point and start the AF operation.

The app automatically switches the focusing mode to single-point live AF (a.k.a. Flexi-
Zone Single).

Since Canon cameras can tell the app when the focusing succeeds, they can’t tell when
it fails, so Kuuvik Capture waits automatically stops the AF operation after a specified
timeout. The timeout can be set in Preferences, and by default it’s 4 seconds.

If your lens has no focus motor or if the lens is in MF mode, the tool 1s disabled.
Clipping Warnings (W)

Kuuvik Capture has four clipping warning layers: two for RAW shadow and
highlight clipping, and another two for processed shadow and highlight clip-

ping.

This tool can be used to quickly toggle the visibility of all four layers at once, so you
don’t have to do it one-by-one when you want to check a composition with no visual in-
terference from the warning layers.

Clipping warnings will be described in detail in Chapter II.
Pan (H)

w Also known as the Hand tool, the pan tool is used to move the image displayed
in the image area. In live view, it works only at 5x/10x zoom levels (as we
learned recently, at Fit level it moves the Point of Operation).

To move the image, just click and drag it.

When a preview image 1is displayed, double clicking it will toggle between 100% and Fit
zoom levels. At any intermediate magnification level a double click will zoom to 100%.

By default the space bar switches to the hand tool while pressed (unless you assigned it
to something else in Preferences).



Zoom (2)

I described basic zooming features while discussing live view, but the zoom tool

0\ adds a few more possibilities. Clicking the image with this tool will gradually
zoom 1in, keeping the clicked point under the cursor during the process if possi-
ble. So you can directly zoom in to the position you are interested in.

In live view it goes through the Fit/5x/10x levels, but on the preview it zooms in in
small steps.

Holding the Shift key down will reverse the zooming direction, and will zoom out in-
stead of in. The zoom cursor also changes from a + to a - to indicate this change.

There are also a few shortcuts for accessing specific zoom levels quickly: 380 will fit the
image on the screen, 381 goes to 100% (10x in live view) and 382 goes to 50% (5x in
live view).

Rotate Left / Right (Shift+R / R)

{—I I—} These tools are used to rotate the image in the image area. When you ro-
tate a preview image, the rotation is also stored in the associated XMP file,
so next time you load the image the orientation will be preserved. And
since it’s in XMP, most RAW converters will pick it up automatically.

Kuuvik Capture also reads the orientation information the camera puts into the files,
and display the images in that orientation by default.

Sharpening (S)

‘ This 1s where things are starting to get interesting. The reason behind this tool 1s
that 1t’s easier to see where the plane of focus is on the image when it’s over-
sharpened a bit. Not grossly over-sharpened, but the right amount of over-
sharpening will make the image pop when you reach focus.

Of course you don’t want the final image to be over-sharpened this way, as it would
ruin the image. That’s why Kuuvik Capture employs the sharpening only for the dis-
play (in other words, it doesn’t affect the final file).

For this scenario (over-sharpening for easier focus), the app’s sharpening has distinct
advantages over deliberate over-sharpening set in a picture style: a) it does not throw
the histogram off and b) it does not affect the recorded image.

Open the Sharpening Options panel by clicking the three dots next the the toolbar icon
(or by pressing *S) to reveal the sharpening amount slider. Set the amount according to
the current camera and shooting situation.



The live view stream and images usually need a different amount of sharpening, so the
amount slider stores different values for live view (including multi-point) and images.

Sharpening is turned on by default.
Focus Peaking (P)

This tool, designed to be both a focusing aid and sharpness assessment tool,

highlights high contrast edges on the image (works in live view, including multi-
point, as well as on images).

The 1image below shows focus peaking on an image.
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The peaking tool has three modes:

e Color. The image remains in color, the edges are highlighted in a solid color.

e Mono. The image is converted to monochrome, the edges are highlighted in a
solid color.

e Mask. The edges are shows in solid white, everything else is black.

You can cycle between these modes by clicking Tools > Cycle Peaking Mode (or by
pressing M). Or you can select the mode directly on the Peaking Options panel (click the
three dots next to the peaking icon or press *P to open it).



Kuuvik Capture has color presets (green, pink, yellow, white) for the edge highlights.
Use Tools > Cycle Peaking Color (or press K) to switch between them. But if you
need another color, just click the colored square on the Peaking Options panel and pick
your color on the displayed color picker.

Two things control how the focus peaking algorithm detects the edges: a) the amount
of sharpening applied to the image with the Sharpening tool and b) the Threshold slider
on the Peaking Options panel.

The 1image on the left shows a low threshold, the right a medium threshold setting.
Threshold values are stored separately for live view and preview images (just like the
sharpening amount).

Let me return to the peaking mode for a moment. To the mask mode to be exact.

The focus peaking ., uuvikcapture File Camera Image Tools View Window Help
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It works in live view,
multi-point live view
as well as on images.



Show Guides (G)

Kuuvik Capture lets you choose from a set of predefined guide templates as
well as lets you place guides anywhere you would need.

You can access the predefined templates from the View > New Guides From Tem-
plate menu item, or from the Guide Options panel (*G). There are three kind of tem-
plates:

e Grids. You can choose from 3x2, 6x4 and 30x20 grids.

 Composition lines. These templates are here to help in making your composi-
tion. The choices are center, thirds, golden ratio, plus lines at 25% edges to help
in stitching.

e Aspect ratio lines. For marking 1:1, 5:4, 4:3, 16:9, DCI 4K, 2.39:1 aspect ratios.

You might have noticed the labels absolute and aspect-relative above the template names.
These are the same for still photography, and will cover the differences in Chapter III.

The 1image below shows a typical usage scenario for guides: making sure that building
features are absolutely horizontal and vertical in architecture photography.
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Click the color picker (colored square) on the Guide Options panel to set the color for the
lines. Note that you can also set the opacity. I tend to use a color and opacity that while
still visible, does not interfere with my current composition.

To move a guide, hover the cursor over it (it will change shape), click the guide and
drag it. You can move around guides created from templates freely.

To add a new guide, click one of the rulers (at the top and left side of the image area),
and drag a new guide from it onto the image area. Existing guides can be removes us-
ing the rulers, too: simply drag a guide onto the rules and it will disappear.

Speaking of rulers, Kuuvik Capture has two different scales:
percents, and thirds/quarters/eighths. To switch between
those, use the View > Ruler Scale menu item, or click the
intersection of the rulers (indicated by the red arrow on the
right).

The percent scale is trivial, but a few word about the third-
s/quarters/eighths scale. Quarters are indicated by longer
marks, eighths by shorter marks. Thirds are where a mark
has a dot at its end.




The Sidebar

I've introduced the sidebar when I talked about the main window. You already saw the
camera selector (at the top), and the Navigator (the topmost panel in the scrolling re-
gion).

Because Chapter II will discuss most of the sidebar panels (Mirror Lock-up, Bracketing
and Intervalometer), as well as the histogram and the buttons at the bottom, I'll only de-
scribe the Exposure panel and some general stuff here.

The panels in the scrolling region can be revealed by shortcuts, like N for Navigator,
AE for Exposure, and so on. The full list is under the Window > Sidebar Panels menu
item. Right-clicking the scrolling region presents a context menu, where you can also
reveal any of these panels. Or expand them all. Or close them all. When you reveal a
panel, it’s opened, and scrolled into view.

We saw how the buttons on the Navigator zoom the live view. They are titled differently
for previews (1:2 and 1:1), as well as there’s a slider, but it works the same way for pre-
views as it does for live view.

OK, that was the general stuff, now move onto the Exposure panel.
It has five fields:
1. Exposure mode,

w EXPOSURE

2. Shutter speed, Manual

1/8 s

3. Aperture,
1SO 100

4. ISO Speed,
5. Exposure compensation.

All these fields are bi-directional: if you change an exposure parameter on the camera,
the field will reflect the change.

On 1-series Canons exposure mode 1s a popup button, so you can select the mode from
here. On cameras with a rotating exposure mode dial, well, Kuuvik Capture has no
magic powers to turn the dial remotely, so you have to do it. But the current mode is re-
flected here.

The app supports Manual (M on the camera), Aperture Priority (Av), Shutter Priority (Tv)
and Manual Bulb (B) modes. If you set any other mode on the camera, the Exposure
panel will say Unsupported Mode, and you will not be able to change any of the exposure
parameters (and some other tools, such as Bracketing, will be disabled).



In manual mode you can set all three exposure parameters. With newer cameras expo-
sure compensation shows the difference between the values you set, and the value me-
tered.

You can initiate exposure metering by either using the camera’s shutter release or via the
Camera > Start Metering menu item (or with the Y key).

Similarly, in Aperture Priority mode the shutter speed field will show the metered value
while metering is active. But in that mode you can also set exposure compensation.

In manual bulb mode the shutter speed field turns into a number entry field, where you
can set the length of the bulb exposure - between 1 and 999999 seconds.

There are a few shortcut keys (and the corresponding menu items in the Camera menu)
that can be used to jump to these fields immediately. They are T for shutter speed, A
for aperture, I for ISO and C for exposure compensation. They work only if Full Key-
board Access 1s enabled for all controls in System Preferences. Kuuvik Capture will tell you
how to do it if it’s not enabled on you Mac.

A green rectangle appears around the control when you press T/A/1/C - and the cur-
sor keys can be used to change values. By default they change by the exposure step in-
crements set on your camera, but by pressing the Shift key the cursor keys will change
it in whole stops.

But since these fields are popup lists, you can click them and select the values from the
popup menu.

LA A 4

At this point you already know a lot about Kuuvik Capture, so it’s time to move on to
the subject of actually capturing images.



Chapter Il - Capturing Still Images

@ Kuuvik Capture File Camera Image Tools View Window Help

Canon ECS 7D Mark Il

1SO 100




OK, you are eager to press that Capture button at the bottom of the sidebar, but where
the captured image will go? Well, press it now, and let’s find out!

Sessions

*
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Sessions are rather simple beings in Kuuvik Capture - each session
1s a folder on your Mac. The folder corresponding to the session is
where the app downloads captured images. The Image Browser
displays thumbnails of images found in this folder.

When you open the app for the first time a default session is cre-
ated in ~/Pictures/Kuuvik Capture in your home folder.

The Image Browser (shown on the left) is used to manage images in
the session: to rate, label and delete them.

The image you select in the browser is loaded into the image area.
The selected image has a white border around it in the browser.

You can select next and previous images using the cursor keys, or
jump to the very first or last image using the \ and “ keys.

Star ratings can be set either by clicking the stars under the image,
or with the 0-5 keys. The 0 key, as well as clicking a star for the
second time, will remove the rating. The ] and [ keys will increase
and decrease the ratings.

Most color labels are also accessible from the keyboard: 7ed (6), yel-
low (7), green (8) and blue (9). The purple and none labels (the latter
clearing the color label) are accessible either from the Image > Set
Color Label menu, or via right-clicking the image area.

Rating and labeling works on the selected image when you use the shortcut keys, but by
right-clicking any thumbnail in the browser you can set these for the clicked thumbnail.
Obviously clicking star ratings for any thumbnail will set the star rating for that image.

Ratings and labels are stored in industry-standard XMP sidecar files, so opening the session’s
folder or a single image in your RAW converter (or creating a hot folder for the session) will

immediately make the ratings and labels available in there. Well, assuming that you converter
can handle XMP metadata.

Ratings embedded into images are also read, but XMP sidecars take precedence.



If you shoot RAW+JPG, downloaded RAW+JPG pairs will be
handled as a single package, but only the RAW file is used for dis-
play. Thumbnails in the Image Browser are marked with a “+”
badge to indicate that a JPG is also present, while the file name

will show just the RAW.

Deleting the package will delete both the RAW and the JPG. _LPX6399.CR2

You can open any image in your favorite RAW converter or photo editor in two ways.
The Open With menu (either from the Image menu or after right-clicking) lists all the
apps on your computer capable of opening the selected image directly. Clicking the
app’s name will open the image in the chosen app. A preferred editor can also be as-
signed in Preferences, and pressing 38E will immediately open in image in the preferred
editor app.

Images having GPS coordinates in their metadata can be shown on a map in Maps
with the Show on Map (8G) command in the Image menu or from the context menu.

To move an image to the trash, press 88 <X] (or choose Move to Trash from the Image
menu or from the right-click context menu).

To change the sort order of the Image Browser thumbnails, use the Image > Sort By
menu, or the right-click context menu. You can sort by file name, date created and rat-
ing, both in ascending and descending order.

Thumbnails displayed in the Image Browser are coming from the RAW files’ embedded low
resolution thumbnail. So there’s no need for time consuming thumbnail generation. But being
low resolution, some pixelation may happen if you resize the image browser to larger sizes.

Hover the cursor over a thumbnail and a tooltip will be displayed showing the image’s capture
date, camera and lens, plus exposure parameters. A lot more can be included by setting the
Metadata tooltips preference to Extended.

You can resize the browser by dragging its side (or via the Window > Image Browser
menu). And completely hide it when you don’t need it (Window > Image Browser >
Hide or, "H).

If you want to create a new session, use the File > New Session... menu item or press
dEN. Of course you can also open a session (File > Open Session... or 380). And if
you want to quickly open the session’s folder in Finder, choose File > Reveal in Finder
(or press 3#F).

Dragging and dropping a folder to Kuuvik Capture (either the running app or its icon
on the Dock) will open the folder as a session. This is a huge time saver if you open dif-
ferent sessions a lot.



Capturing a Single Image

Capturing a single image is easy: click the Capture button on the bottom of the sidebar,
or press K.

You can also reconfigure the space bar in Preferences to mirror the functionality of the 38K
shortcut.

Several things happen in response to starting the capture. The camera is set to a com-
patible “single frame” drive mode if necessary and image quality is set to RAW,
RAW+JPG or JPG based on what you set in Preferences. JPG files are always large/fine

quality.

Single frame drive mode is required because of how Canon’s remote control interface
works. The app leaves single frame, silent single frame, 2s and 10s self-timer as set. In
case other drive mode is set on the camera, it will be changed to single frame or silent
single frame (the latter if silent continuous was set on the camera). And since one of
the main goals of Kuuvik Capture is to help you in creating the highest quality images,
RAW is the natural choice. But since a few of our customers asked for JPG support,
the app can also do that.

Captured images are recorded onto the card in the camera and also downloaded imme-
diately. With RAW+JPG you also have the option to not download the JPG. In case
you don’t have a card in the camera, files will be still downloaded to the computer.

By RAW I mean real, proper RAW. SRAW and mRAW aren’t, so they are not supported.

Of course you can also capture an image by releasing the shutter on the camera. In this
case Kuuvik Capture has no chance to set drive mode or image quality, but will do the
best it can.

You can use a regular cable release connected to the camera to initiate captures.

The newly captured and downloaded image appears in the Image Browser and also
loaded into the image area.

Kuuvik Capture extracts and displays the embedded JPG preview from the downloaded RAW
file.

From this point on, the app’s tools you learned in Chapter I can be used on the pre-
view: sharpening, focus peaking, markers, guides, panning, zooming, rotation, etc.

You also see exposure parameters used to capture the image below the histogram area.



The Dual Histogram

You are familiar with histograms. But you might not be familiar that the usual his-
tograms (on the back of your camera and in your favorite RAW converter) miss infor-
mation that could be an important factor when deciding your exposure.

Regular histograms (I'll call them processed histograms) are generated from the image af-
ter RAW conversion. Parameters like white balance, picture style, color space and even
sharpening have a huge influence on the histogram, and may hide important issues.
Misleading you to think that you have a correct exposure, but in fact you might clip
channels.

Kuuvik Capture’s Dual Histogram has a RAW-based
histogram (top) along a processed one (bottom) to
display information from different vantage points.
The RAW-based one reflecting the image’s data be-
fore conversion. They are complementary instru-
ments helping you to precisely assess an image’s
exposure.
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Naturally, the RAW histogram is displayed for RAW files. If you have a JPG image
loaded, or in live view, only the processed histogram will be available.

The RAW histogram and corresponding clipping warning layers are generated in the back-
ground, so it may take a moment until the RAW histogram appears. It is not necessary to
wait for the RAW histogram, it is possible to move to or capture another image. But you can’t
delete or purge images during this time. You can also switch from the automatic RAW his-
togram generation to manual, a setting discussed later on.

In case of RAW files, the processed histogram is generated from the JPG preview im-
age that every RAW contains (this 1s what you see in the image area, and this is the
source of the histogram shown on the camera’s LCD). This represents how the image
was processed by the camera. Your RAW converter will almost certainly convert it in a
different way, so the final word on exposure still belongs to the converter. But the cam-
era’s interpretation gives a solid starting point.

For checking highlight and shadow clipping at a glance, you’ll see warning signs on the
left and right of the histogram if the app detects that more than 0.01% of the image’s
pixels are clipped. There are a different set for RAW and processed data.

While processed clipping could be avoided by changing conversion parameters, RAW
clipping 1s always hard fact, indicating unrecoverable data loss. It’s a good practice to
avoid RAW clipping wherever possible. Even tools like highlight recovery in your RAW
converter will be more effective if the RAW channels are not clipped.



The processed histogram also indicates the image’s color space. For live view and
movie recording the camera always serves video frames in sSRGB — even if you set your
camera to Adobe RGB.

This is how the Dual Histogram works, but let me dig a bit deeper into why one would
need it. I'll discuss the effect of white balance and color space choice, but will leave ex-
perimenting with other processing parameters as an exercise to the reader.

Let’s begin with white balance. Cameras see
quite a bit differently than humans do. On the

right i1s how a Canon EOS 7D Mark II sees a
ColorChecker chart, for example.
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Thanks to white balancing, you don’t get this
greenish mess normally.
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During RAW conversion the converter multi-
plies red/blue channel values, effectively
stretching or compressing them, to reach your chosen white balance. For the Col-
orChecker image, the red channel should be stretched by about 2x, and the blue chan-
nel about 1.4x.

White balance is is always represented as RGB coefficients during RAW conversion, not with
color temperature/tint as RAW converters and cameras present this data to you. Color tem-
perature is a construct to handle these numbers in a more user-friendly way. And the way
these coefficients are mapped onto color temperature is a proprietary process for each converter.
This is why you get completely different white by using the same Kelvin value in different
RAW converters.

Comparing the RAW and processed histograms on the previous page’s example clearly
shows how white balancing pushed the peaks of the red and blue channels to the right.

What happens if the red channel had data above the mid-point and stretched by a fac-
tor of 2?7 Well, it will be clipped. This is white-balance-induced clipping, and the usual
histograms show this.

But in the other direction, when a channel 1s com-
pressed (with a coefficient less than 1), the processed
histogram might show that everything is in order,
while in reality a channel is already clipped. The result
1s detail-less flat areas with no color variation in satu-
rated regions. And the same applies to shadow areas

IS0 1600 too, with channels lifted out of underexposure. The
latter happens all the time when I do astrophotography




and the exposures are too short (as you see on the example on the left). The RAW his-
togram easily catches this.

I must note that we apply gamma correction to the RAW histogram, and thus it’s not entirely
RAW. Why? Because the way the sensor captures the world doesn’t agree with how humans
see. The role of gamma correction is to redistribute tones to match human vision. So it’s not
the everything-crammed-to-the-left kind of RAW histogram you may encounter in some apps
and geeky articles. Instead, it’s something that makes sense for a human photographer.

Now on to how color space choice affects the processed histogram. Canon cameras of-
fer sSRGB and Adobe RGB. This specifies the color space JPG files (including embed-
ded previews is RAW files) will be converted to.

I made two photos of a regular ColorChecker chart. One with setting the camera to
sRGB and another with setting it to Adobe RGB. Lighting and exposure were the same.
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There’s absolutely no clipping in the RAW data (the RAW histograms are identical).
And there’s no clipping when converted to a sufficiently large color space - Adobe
RGB. But in sSRGB the histogram becomes more elongated and both highlights and
shadows are clipped. This is a good example of color-space-induced-clipping. And can
be easily fixed by choosing a larger color space. But if you are shooting JPG and even
Adobe RGB is not large enough... It’s a reason to switch to RAW.

One consequence of this 1s that the histogram during live view (which 1s always in
sRGB) may show clipping while the captured image’s histogram (in Adobe RGB) not.
And even a histogram from an Adobe RGB embedded preview might show clipping
while there’s absolutely no clipping in the image when converted to ProPhoto RGB in
your RAW converter.

I’'d recommend to treat these processed histogram clipping warnings as different levels.
The sRGB warning in live view goes off first, this should ring a bell in your head to
watch more closely after taking the image, as there may be a problem. After taking a
picture, if Adobe RGB shows clipping, then it’s time to either check it in your RAW
converter or back off a little bit.



Finally I'd like to mention another tool that goes along the non-white-balanced idea.
This is Unitary White Balance. Unitary WB is a special WB where the channels are not
stretched and compressed at all (their coefficients are 1). Images taken with Unitary
WB will have the previously shown green cast in their JPG previews (RAW data is not
affected). To program Unitary WB into the camera’s Manual WB slot, click Camera >
Set Unitary White Balance in the menu.

Clipping Warnings

As mentioned in Chapter I, there are four clipping
warning layers: two indicating RAW clipping and
two for processed data clipping.

The saturation of each warning layer’s color in-
creases as more channels are clipped for a pixel, as
you can see on the left (with only the RAW layers
shown).

Processed clipping warnings are also available dur-
ing live view and movie recording. Just keep in
mind that exposure simulation should be enabled
on the camera for the best results (otherwise live
view will not reflect your current exposure).

RAW and processed layers can be
shown separately or combined (the de-
fault). When used together, the pro-
cessed layer usually triggers first. To be
able to distinguish the two types when
used together, you can choose from dif-
ferent color themes for the processed

warning layers (RAW layers are always
red/blue).

There are a bunch of items on the
View menu, as well as on the image’s
right-click context menu and on the histogram’s context menu. You can toggle each of
the four layers separately, or turn the whole stack on and off with the Clipping Warn-
ings command (or by pressing the W key or clicking its toolbar button) when the warn-
ings get in the way of evaluating composition.
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This way I always have red/blue warnings: processed ones during live view and for
JPG files, and RAW ones for RAW files.

The default is yellow/purple for the processed warnings.

The Inverse theme is a special one. Instead of being multi-level, it will invert the pixel
where one of the channels is clipped, thus overexposed red becomes cyan, yellow be-
comes blue, and so on.

Monochrome Mode

This 1is a special viewing mode that converts the image displayed in the image area into
monochrome. Everything else (the image browser, navigator) will remain in color.
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It is similar to the Mono peaking mode, and in fact they both display the luminance
channel (the L in Lab mode) of the image. But Monochrome mode does not activate
peaking. They are interconnected, though. Turning on Monochrome mode when peak-
ing 1s active, and is in Color mode will switch peaking into Mono mode. Turning off
Monochrome mode when peaking is active in Mono mode will switch peaking into Color
mode. If peaking is active in Color mode when Monochrome mode 1s turned on, it will
switch into Mono mode. Choosing the Color peaking mode will turn off Monochrome
mode.

Monochrome mode is also available during live view and movie recording. But unlike
the Monochrome picture style, it only converts the image into grayscale for display.
Recorded images and movie files are not affected.

Block Boundary Artifact Reduction

Kuuvik Capture uses the embedded pre-
view JPG when displaying RAW files.
Unfortunately, these previews aren’t the
highest quality — cameras try to save
space by higher JPG compression. The
downside 1s that when one sharpens
such an image, 8X8 pixel compression
block boundaries may become visible, as
you can see on the magnified image to
the right. It is especially distracting on
large homogeneous dark and light sur-
faces, and makes judging image quality a harder task.

To combat this, Kuuvik Capture has a block boundary artifact reduction function.

On this image most of the artifacts are
gone. Of course permanent damage
done by low quality JPEG compression
can’t be reversed completely, but the
magnified image is certainly less prob-
lematic this way:.

The function is active by default, but can
be turned off in Preferences if you don’t
need it. Yes, there are situations, like
hard straight edges in architecture and
product photography, where the reduc-
tion might introduce its own artifacts. It is a tool useful in most situations, and not use-
ful in some. Use it accordingly.




Mirror Lock-Up

~ MIRROR LOCK-UP The third panel from the top on the sidebar control mirror
lock-up on the camera. The switch on the title of the
panel indicates whether mirror lock-up 1s enabled on the
camera (it’s enabled if the switch is green).

Auto-Release 3 s

You can switch mirror lock-up on and off using this switch, via the Camera > Mirror
Lock-Up menu item, by pressing 38U, or on the camera.

Some entry level cameras do not support mirror lock-up at all. The 1Ds Mark III does not
support mirror lock-up during tethering. The function is disabled on these cameras.

With Canon cameras you need to press the shutter release twice to capture an image if
mirror lock-up is active. Kuuvik Capture can automate this for you. Just set the time
you want to wait between flipping up the mirror and releasing the shutter with the
Auto-Release field. Values range from 0.5s to 15s.

Canon added a similar function to the 5DS and 5DS R, but the auto-release time is limited to
2 seconds. It is usually not enough when using such a high resolution camera. While Kuuvik
Capture will work with this in-camera auto-release, it is recommended to use the app’s release
timer instead.

Or you can turn the auto release off (choose Off from the popup) to switch it back to
working the usual way. But how this usual, double-trigger way works different from
camera to camera.

« The 50D and 5D Mark II provide no information about the mirror’s position to
Kuuvik Capture. In this case the Capture button changes title to Trigger. You
have to press it twice (first flips up the mirror, second releases the shutter). The
app doesn’t know if you flip the mirror up on the camera, though.

* On all other cameras Kuuvik Capture can track the mirror’s position, so the
Capture button changes title to Mirror Up when the mirror 1s down, and back to
Capture when the mirror is flipped up. If you flip the mirror up from the cam-
era, the app follows this as expected.

Mirror lock-up settings will be ignored if you initiate a capture from live view, since the
mirror is already flipped up.

Here’s something you need to know about mirror lock-up and live view. Some newer Canons
(5DS/R, 1D X Mark II, etc) feature an electronic first curtain shutter (EFCS), which induces
even less vibrations than regular mirror lock-up. EFCS is automatically used when you initi-
ate a capture from live view (but not otherwise).



Exposure Sequences

Kuuvik Capture supports different exposure sequence types: auto-exposure brackets, fo-
cus brackets and intervalometer sequences. You can even combine the brackets with in-
tervalometer sequences.

Once a sequence is configured and ready to run, the Run Sequence button in the lower
right corner of the sidebar becomes enabled. Press it (or choose Tools > Run Sequence
or press 36R) to start the sequence. During sequence execution the image area show a
progress bar.
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Running sequence - 61%

Stop

The camera 1s locked during the entire sequence to avoid any potential interference.

As execution proceeds, downloaded image appear in the Irmage Browser. Images cap-
tured during a sequence are marked with a color label - you can set the color in Prefer-
ences.



Auto-Exposure Brackets

Bracketing can be enabled with the switch in the title of v BRACKETING
the Bracketing panel (or via the Tools > Bracketing
menu item or by pressing 38B). The first field on the
panel specifies the type of the bracket. Aperture, shutter
speed and ISO are the auto-exposure brackets Kuuvik Number of Shots 7
Capture supports. Which of those three are available Step 12/3
depends on which exposure mode the camera is in:

Exposure : Shutter Speed

Baszeline Darkest

« All three types are available in manual mode.
*  Only ISO is available in aperture (Av) or shutter priority (Tv) modes.
« Aperture and ISO are available in manual bulb mode.

Baseline specifies which frame of the bracket is represented by the current parameters
on the Exposure panel. If you ever used auto-exposure on your Canon, it works by spec-
ifying the middle frame - that is, you will make some frames darker, some frames
brighter than that. But in practice what you know is how either the darkest or brightest
frame should be exposed in the bracket, and roughly how many frames you need. With
the Baseline setting you can do exactly that: tell Kuuvik Capture which end of the
bracket you have specified in Exposure. It can be either the darkest, or the brightest frame,
or even the middle frame if you really need that.

Number of Shots and Step are both self-explanatory. You can go up to 15 shots per
bracket, and the step size can be set up to 3 stops.

The colored squares at the bottom is the bracketing monitor. The number of colored
squares correspond the number of shots you set above. The baseline frame is indicated
with a white border around the colored square.

Green squares mean that the given frame will be executed with no issues. Yellow means
that the step size between the given frame and the neighboring green frame 1s less than
what you specified, but there’s still a difference. Why could this happen? Because you
ran out of the settings range the camera is capable of. For example you wanted an ex-
posure longer than 30 seconds. Red means that there’s no difference between the cur-
rent frame and the neighboring green or yellow frame.

Shutter speeds in the above screen shot are the following:

1/8s 0.4s 1.3s 4s 13s 30s

You can see why the sixth frame marked yellow, and the seventh red. In general you
want to avoid red frames, since they will just waste storage space. If you hover the cur-



sor over the green and yellow squares, a tooltip will appear showing the varied expo-
sure parameter for that frame.

If you also turn on mirror lock-up, then it will be used for each frame of the bracket.

On EOS-1 series cameras the mirror is flipped up at the beginning of the sequence and only
the shutter is operated for each shot.

The best way to use Kuuvik Capture’s bracketing is to be in manual exposure mode and
set everything up according to your needs.

Camera Controlled Brackets

While it is not recommended to use the camera’s built- ~ BRACKETING
in auto-exposure bracketing with the app, it automates
bracket execution even in this scenario. It reads AE

bracketing settings from your camera and displays fARaling: [ MOe
them.

Controlled by Camera

The bracketing monitor is not available in this case.

White balance bracketing is not supported, and if you
happen to set it the message Unsupported Configuration
will be displayed in place of the bracketing monitor. Click the question mark after the
message to display more information about the problem and how to solve it.

Flash exposure bracketing (FEB) is also unsupported due to camera limitations. But
there’s a trick to simulate it utilizing the intervalometer. More on this later.

The EOS RP introduced in-camera focus bracketing. Kuuvik Capture handles it as an-
other type of camera controlled bracket. The camera’s focus bracketing settings are dis-
played in the app, but you can change them only on the camera. When camera
controlled focus bracketing is active, hitting the Capture button will run the entire
bracketing sequence. Note that the images are captured with electronic shutter, that is,
they are prone to severe rolling shutter effect.

But since Kuuvik Capture has real, proper focus bracketing, I'd highly recommend to
use that.



Focus Bracketing

+ BRACKETING With focus bracketing you can drive the focus in AF-ca-

pable lenses. Each focus bracket starts from a baseline

point. If it is set to Closest, then Kuuvik Capture will

move the focus away from the camera during the se-

Number of Shots 20 > quence. If it 1s Farthest, then the app will move the focus
Step A towards the camera.

Focus

Baseline Closest

A focus bracket can consist of a maximum of 100 shots.

Step size 1s a tricky thing. You can set Small/ Medium-
/Large, but what they mean? Unfortunately the exact focusing distance change for these
steps vary from lens to lens. The multiplier between small/medium and medium/large
also varies from lens to lens, so it’s something you need to experiment with and mea-
sure for your lenses. As a starting point, small steps is what you get when driving the
focus with the cursor keys in live view. Medium step size is what you get then driving
the focus while holding Shift.

Focus bracketing utilizes live view on the camera.

Silent LV shoot. may need to be disabled in the camera’s menu if you intend to use flash dur-
ing focus bracketing sequences, otherwise the flash may not fire.

Just like with auto-exposure brackets, mirror lock-up can be combined with focus
brackets.

Kuuvik Capture tries to move the focusing distance back to the starting point after a fo-
cus bracket finishes. But on some camera/lens combinations it might not position the
lens back to the exact starting position.

Intervalometer and Self-Timer
~ INTERVALOMETER
The role of the intervalometer is to let you execute a
number of single shots (or brackets) after a specified
time passes. If bracketing 1s disabled, it will execute sin-
gle shots, and if bracketing is on, then it will shoot the Number of Shots
specified bracket. Pretty straightforward.

Beginning Delay (sec)

Trigger Interval (sec)

Beginning Delay is the amount of time you want to wait before the first shot. The time
Trigger Interval specifies 1s interpreted as between the start of the shots (and not between
the end of one shot and a beginning of another). So you need to be careful to choose a
longer interval than your exposure time. No problem if you fail to do it, just the shots
will be executed one after another with no wait. It can be even helpful if you just want
to execute the same shot a number of times (in this case just set 0 as the interval).



This is the way the trick to use flash exposure bracketing (FEB) works. Set up FEB on your
camera, set the number of shots in the intervalometer and set the interval to zero. Kuuvik
Capture will trigger the shots and the camera will vary flash exposure between them.

With Number of Shots set to 1, the intervalometer becomes a self-timer. Trigger Interval 1s
ignored in this case. It is recommended to use this method instead of the camera’s self-
timer drive modes.

Self-timer drive modes on the camera are supported to be able to use the IR remote (RC-
1/5/6), which demands the use of self-timer drive modes.

Intervalometer sequences can be combined with bracketing and mirror lock-up.

Culling

Culling is the process of selecting your best shots, or keepers in a session. It is based on
the star ratings I had introduced at the beginning of this chapter.

Contrary to the usual “throw out the bad ones one-by-one”, Kuuvik Capture sports a
“mark the best & ditch the rest” concept of image culling. During the years, I found the
negative approach (throwing out the bad ones) impacts my creative process in a very
bad way: I've been concentrating on the bad images, instead of the standouts. It was a
kind of mental torture for me.

With the app, I just give stars to the best images, to those that I really like (and those
whose technical properties are also good). Then ask the app to trash the others (Image
> Purge Unrated menu item or 38P).

You also have the option to decrease star rating of remaining images, and start the
process all over again. To do it, click the Image > Purge Unrated and Decrease Rating
menu item or press <> 38P.

It’s simple, intuitive, and fosters positive thinking about the good images.

One of the side effects of sessions being simple folders is that you can use Kuuvik Capture to
cull your previous shots. Even ones not captured with the app, like a wedding or sports event.
Just open the folder you want to cull as a session. I use it all the time to select the keepers from
my bird shoots (letting me to go through around 2000 images a day in a breeze).

Purged images are moved to the Trash, so you can restore them from there if you acci-
dentally purged some worthwhile photos.



Chapter lll - Recording Movies
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Tethering can also bring advantages to the cinematographer. Think about cameras
placed in hard-to-reach locations, or enclosed in a crash box. It’s much easier to set up
and execute your shot if you see what you are doing.

Turning on Movie Mode

Newer Canon cameras are equipped with a movie mode switch. On these, you just flip
the switch and it’s done.

But on models with no such switch, movie mode must be switched on in the menu. The
exact procedure is described in your camera’s manual, so I'm not going to replicate it
here. You need to look for Live View/Movie func. set. and under LV func. setting
choose Sills+movie with Movie display.

In both cases, Kuuvik Capture will immediately start live view (meaning that it will
close the camera’s menu).

In Movie Mode still shooting is not possible from Kuuvik Capture. Even if the camera can
shoot stills in this mode, the app will ignore them and will not download them.

Since the USB port has no sufficient bandwidth to stream movies, they are recorded to
the card in the camera only. So unlike in stills mode, you must have a card in the cam-
era.

Kuuvik Capture does not download recorded movies, you need to do it after the shoot
outside the app.

Some older Canon cameras limit movie shooting while using Wi-Fi tethering. I guess
the reason 1s a thermal budget issue: both movie recording and Wi-Fi produce a large
amount of heat, and cameras can’t cope with that. The external WFT-E7 transmitter
brick (since it’s not inside the camera, meaning it does not affect camera heating) al-
ways worked in our tests, as did newer models.

If your are planning to do movie shooting while using Wi-Fi1, I'd highly recommend to
check your camera before the actual shoot - a large message usually pops up on the
camera LCD if movie shooting is not supported with Wi-Fi.



Live View in Movie Mode

The app’s main window changes slightly in movie mode.
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The Capture and Run Sequence buttons are replaced with the Record/Stop button (1).
Gray bars (2) are displayed between the sensor’s 3:2 aspect ratio and the recorded
movie file’s aspect ratio. So if you shoot in 16:9 or DCI 4K, bars will be above and be-
low, and on the sides if you shoot 4:3.

The aspect ratio of the live view stream in movie mode varies greatly from camera to camera.
Some provide 3:2. Some provide 16.9 if recording in 16.:9 but 3:2 if recording 4.3. It’s a com-
plete mess, so we’ve decided to make it uniform, thus the gray bars were born.

The live view’s frame rate and resolution are the same as in normal live view.

Depth of Field Preview is disabled, since in movie mode the camera already stopped the
lens down. Also disabled is the Multi-Point Live View. And of course mirror lock-up,
bracketing and intervalometer are meaningless in move move, so their associated side-
bar panels are completely ignored. The Image Browser 1s disabled.

Sharpening, focus peaking, zooming, panning, focus drive, etc. are available just like in
standard live view mode.



You can stop live view in movie mode, but have to start it again before starting record-
ing. This 1s a way to save battery while the camera is set up but waiting for the scene to
unfold.

Canon Log Mode
When the camera is set up to record in C-Log, the picture

style control changes to indicate this. Recording bit depth
is also displayed.

CB° Style C-Log 8bit

C-Log mode cannot be changed from the Kuuvik Capture, only on the camera.
Live view shows the C-Log image, view assistance 1s not available yet.

Note that recording to the card is not possible in some cases (like 10bit C-Log on the
EQOS R). The record button in the app, just like the the record button on the camera,
will not function in these cases.

Starting and Stopping Recording

It’s done the same way still captures are started: click-
ing the Record (the title will change to Stop when
recording starts), with 38K or with the space bar if you
configured it to do so in Preferences, or via the Cam-
era menu.

A recording time is also displayed under the his-
togram. But since Canon cameras do not provide time
code through the tethering interface, this is just a sim-
ple time started along the camera’s. Meaning that
recording time displayed on the camera and in the app may slightly differ.

Zooming is disabled during recording and the zoom level is automatically set to Fit.

Some Canon cameras lower live view resolution during recording, so if you notice that the live
view image becomes a bit blurry during recording, then this is the reason.



Aspect-Relative Guides

When I introduced guides, I mentioned that there’s something called aspect-relative

guides, and they are for movie mode only.

The position of aspect-rel-
ative guides are calculated
relative to the aspect ratio
of the recorded movie.

For example if you are
recording 16:9 HD, the 4:3
guides are placed in a way
to indicate the 4:3 crop
within the 16:9 image.

The position of these
guides will change if you
change the recording for-
mat to one with a different

aspect ratio. Absolute guides (such as grids) are always displayed at the same position,

regardless of the recording format.

Custom guides are absolute, and thus they do not follow recording aspect ratio
changes. Also, if you move a guide, it will turn the current template into custom, mean-

ing that the guides become absolute.



Chapter IV - Supplementary Functions

@ Preferences

Capture  Session  Display  Behavior

7 Prevent auto power off
72 Synchronize date/time with the Mac
7 Apply copyright information template Edit...

72 Turn on the LCD when live view is started from the app

The LCD is always turned on if live view is started from the camera.
Autofocus timeout: = 4 seconds |

Network timeout: | 10 seconds | &

Use longer times to avoid connection drops on slow Wi-Fi and Ethernet networks.




Setting Preferences

The Preferences window is accessible by pressing 38, or by clicking the Kuuvik Cap-
ture > Preferences... menu item.

Let me g0 trough the settings @ Preferences

one by one. , _ _
Capture  Session Display Behavior

Canon cameras go to sleep af- 7) Prevent auto power off

ter a the time set in the menu. .4 Synchronize date/time with the Mac

When a camera g0¢€s to Sleep, 4 Apply copyright information template Edit...

1t disconnects from Kuuvik 4 Turn on the LCD when live view is started from the app

Capture. Wlth the Prevent aul‘o The LCD is always turned on if live view is started from the camera.

power Offoption you can Clr- Autofocus timeout: 4 seconds | &

cumvent this Sleep. Network timeout: ~ 10 seconds |

Use longer times to avoid connection drops on slow Wi-Fi and Ethernet networks.
Turning on Synchronize date-
/time with the Mac tells Kuu-
vik Capture to update the camera’s clock upon each connection. It will set the date and
time zone to match that of your Mac. It does the update even if GPS-based time setting
is active in the camera.

You can manage the author and copyright settings of your cameras with Kuuvik Cap-
ture’s copyright information template. It will be discussed in detail in the next section.
But this is the place where you can enable/disable the template with the Apply copyright
information template preference (and edit it with the Edit button).

Both time synchronization and copyright template application are done immediately
on all connected cameras when you enable them.

The next setting controls whether the camera’s LCD is turned on when you start live
view from within the app.

If you turn this preference off, the camera’s LCD will remain turned off to conserve
battery. But you can turn the LCD on any time with the live view button on the cam-
era.

When you start live view directly on the camera, it’s LCD will turn on regardless of

this setting (chances are that you engaged live view on the camera because you want to
look at the LCD).

With Autofocus timeout you can specify after how much time the app gives up the AF op-
eration. The range 1s 2/4/8/16 seconds.



Network timeout tells the app how much time is allowed for intermittent network errors
to clear. A longer network timeout may prevent the camera to disappear from Kuuvik
Capture, but at the expense of delaying the detection of actual issues (such as when the
battery dies).

The default 1s 10 seconds, which we found to be suitable for most Wi-Fi networks. You
can go as low as 5 seconds or as high as 30 seconds. My personal preference is to go
with the lowest number, and raise it in the presence of connectivity issues.

Image quality controls whether ® Preferences
you shoot RAW, RAW+JPG c : . .
amera Session Display Behavior
or JPG. JPG files are large-
Image quality: =~ RAW + JPG &} Download RAW files only

/fine ones, since we still want
to keep image quality at the
highest possible level. When
you choose RAW+JPG, the
Download RAW files only option
appears so that you can set
whether the JPG files will re-
main on the card (by default),

.4 Force native image aspect ratio (3:2)

or downloaded along the
RAWSs. With the JPG image quality setting files are always downloaded of course. In
case of RAW+JPG pairs the RAW file is used for display.

There’s also an option to force the native 3:2 image aspect ratio. Aspect ratio control 1s
a complete mess on Canons. You have two settings to cope with, and sometimes get a
cropped JPG file and other times a full resolution JPG with metadata to indicate the
crop. To make things worse, RAW converters and Photoshop tend to change how they
interpret cropping metadata from version to version. We simply don’t want to get in-
volved in this messy situation. So by default Kuuvik Capture forces the camera default
3:2 aspect for all images. You have the option to turn it off, if you really really know
what you are doing and need non-3:2 images. But you were warned.

Preferences By default Kuuvik Capture
_ _ warns you before moving im-
Camera Capture Display Behavior
. ages to the Trash and before
Warn before moving images to the Trash purging images These warn-
Warn before purging unrated images il’lgS can be turned Off Wlth the
Set color label on sequence images: | Yellow < two “Warn. ) .” SettingS.
Metadata tooltips: = Extended <
Preferred editor: [ Adobe Photoshop CC 2018 , The name of Set color label on

sequence images speaks for itself.
This is the color all images
captures shot as a part of a se-




quence 1s labeled with. Choices are all five supported label colors, plus None, if you
don’t want to add color labels automatically.

You can control the amount of information Metadata tooltips in the Image Browser dis-
play with the next preference. Basic includes date, camera name, exposure parameters
and lens focal length. Extended adds color space, copyright, artist, camera owner, cam-
era serial number, and GPS coordinates.

The Preferred editor is the RAW converter or image editor of your choice that you would
like to use to quickly open any image from Kuuvik Capture. By pressing 38E (or via the
menus, but I bet that the keyboard shortcut will be used more often). You can designate
any app that is registered as an editor for CR2 or JPG files on your Mac as the pre-
ferred editor.

Lightroom is not registered as an editor, and is unable to open individual files without import-
ing, you will not see it listed. If you use Lightroom, a hot folder should be set up in Lightroom
for the Kuuvik Capture session folder, and it will automatically import images from there.

Beginning with Kuuvik Cap- 8) Preferences

ture 3.3 image sharpening is , _
kept at the same Visual amount Camera Capture Session Behavior

lf you 7ZooOm iIl and out. PI'CVi- Increase image sharpening when zooming out

OUSly sharpening was Shghtly ./ Reduce block boundary artifacts

stronger When you zoomed 4 Automatically load RAW data for histogram and clipping warnings
out. You can restore this older 4 Prevent display sleep

Computer sleep is automatically prevented while a camera is connected.

behavior with the Increase image
sharpening when zooming out op-
tion. It affects image loaded
into the image area, but not
live view and multi-point live
view.

Block boundary artifact reduction can be turned off with the next option. When turned
on, the function activates for RAW files between 75% and 100% zoom levels and if
sharpening is also active — block boundaries are eliminated by the interpolation process,
and not visible at all when you zoom out. It is automatically disabled for JPG files and
live view.

RAW loading consumes a lot of energy, and there are situations when conserving bat-
tery is of paramount importance. Turn off Automatically load RAW data for histogram and
clipping warnings, and no energy-consuming loading will take place automatically. The
default 1s to automatically load RAW data, so that both the RAW histogram and clip-
ping warnings could work as expected. With the Prefer RAW clipping warning option
you’ll see the processed warning layers until the ones generated from RAW data arrive.



Should you need the histogram or the warning layers later
on, you always have the option to load the RAW data
manually. Just click the placeholder on the RAW his-
togram, or choose the Load RAW Data command from

the menu, or press 38L.

Computer sleep is automatically disabled on your Mac as
soon as you start Kuuvik Capture. But the display is al-

ISO 400

lowed to go to sleep. To disable this, check Prevent display sleep.

Space bar: | Capture

Camera Capture

v

Preferences

Session

Mouse wheel [ trackpad scroll: | Focus

Display Sehaviol

(§59)

72 Reverse direction

Choose between the two possi-
ble functions of the space bar
with the Space bar setting. The
choices are Pan (to pan the im-
age as described in Chapter I)
and Capture (which will mirror
the 38K shortcut to capture
images and start/stop movie
recording).

The mouse wheel (and its as-
sociated gesture on the track-

pad) can be assigned to the following three functions (with the Mouse wheel /trackpad

scroll setting):

»  Scroll, which will scroll both the magnified live view and the preview.

» Zoom, which can be used to zoom into and out of the preview image.

»  Focus, to drive focus in live view and multi-point live view.

Choosing Zoom or Focus reveals a setting to reverse the wheel and scroll gesture direc-

tion.



The Copyright Information Template

While you can set both the author (aka artist in EXIF) and copyright information from
the camera, keeping the copyright info up to date when a new year comes takes some
effort. If you ever noticed a previous year’s copyright notice only when exporting the
image from Photoshop — then this feature will be golden for you.

I always set the author to my name, and the copyright notice to (of course with the ac-
tual year):

Copyright (C) 2019 Laszlo Pusztai. All rights reserved.

This satisfies the requirements of several countries (some requiring the copyright sym-
bol, others the “copyright” word to be present in the notice, and even some require to
declare that you reserve your rights) and is something I have been using for decades. As
you may have guessed, the problem is keeping the year current.

The copyright information template can set both the author and the copyright notice in
new cameras, as well as keep the notice updated when a new year comes. You just have
to connect your camera and it’s done automatically.

But you have to create a template first and instruct Kuuvik Capture to apply it when a
camera is connected. To create your template, bring up Preferences, and click Edit after
the check box titled Apply copyright information template on the Camera tab. If you
turn on the check box on for the first time it will automatically display the editor.

Here’s how my template
looks in the editor.

The easiest way to set up
your copyright info is to
type your name in the Au-
thor field and click OK.
The defaults will take care
of creating the appropriate
copyright notice in the for-
mat shown above. But you
can also customize it.

You can use tokens to in-

sert predefined information

snippets, such as the cur-

Preferences

Author: %0
Copyright:

Copyright field tokens:

Y%a - author name

%c = (C) in menu and EXIF, @ in IPTC

%0 - owner name (can also be used in the author field)
%p = % character (can also be used in the author field)
%Yy = current year

Preview: Menu /EXIF

Author / Artist: Laszlo Pusztai
Copyright: Copyright (C) 2019 Laszlo Pusztai. All rights reserved.

Apply: If owner name is Laszlo Pusztai

Cancel

rent year. All the tokens are listed on the editor itself. One of them is %o, which will be
replaced with the owner name currently set in the camera (setting the owner name 1s



discussed in the next section). For example, I prefer to set the author to be the same as
the camera owner (me) and thus use %o as the author name. I leave the copyright field
at its default. But if you have a long name, you may need to change it, as Canon cam-
eras have a limit on how long the copyright notice could be. Jean-Baptiste Emanuel Zorg
(apologies to Luc Besson and Robert Mark Kamen) will definitely need to use a cus-
tomized template... But in any case, the Preview section will give you a live preview of
how the expanded template will appear in the camera.

If your camera is IPTC capable (EOS R, 5D Mark IV, 1D X Mark II), then the app will
also set up and activate IPTC metadata in the camera.

Let me stop here for a second. IPTC information you set must be separately activated with
turning Add IPTC information on in the camera’s menu. Kuuvik Capture does it for you.
But it always activates IPTC, and if you don’t want this, then you have to turn off applying
the copyright information template.

If you already have IPTC metadata in place, then the creator and copyright fields will
be updated. You can see how the IPTC fields will look like by changing the preview
type to IPTC (instead of Menu / EXIF). The most important difference is that you can
use accented characters in IPTC fields, but only ASCII is allowed for the camera menus
(that will be written as EXIF fields into files). The app will automatically convert any
non-ASCII characters entered into the author and copyright fields for the menu, includ-
ing the copyright symbol itself. But will keep the accented ones in IPTC fields.

The template can be applied to all cameras unconditionally, or you can set up a filter
limiting the application of the template to cameras having a matching owner or artist
name field. In case you regularly connect other people’s cameras and don’t want to
mess up their copyright info.

With my template described above, when a new camera arrives, I only set the owner
name, and the copyright info template takes care of everything else.

Setting the Owner Name

The camera owner’s name cannot be set from the camera itself, this functionality only
available to tethering/remote control apps. Why? Because if your camera gets lost (or
stolen), chances are that the new “owner” had no chance to change it yet. So the device
could be identified. This name is also embedded into all the images made with the cam-
era, extending the ability to identify the original owner. It is not a perfect anti-theft
measure, but might be helpful when recovering your lost property.

It’s pretty straightforward to set or change the owner name in Kuuvik Capture. Connect
your camera, and click Camera > Settings > Edit Owner Name... in the menu.



If you have a copyright information template that uses the owner name token or is fil-
tered for owner name, then the template is automatically applied after changing the
owner name.

IPTC Export/Import

Kuuvik Capture can export and import IPTC information from/to the camera. This
function uses the same XMP files EOS Utility (as well as our ShutterCount app) uses for
its similar function, so you can freely mix and match the two apps to manage IPTC in-
formation. There’s an addition in Kuuvik Capture, though. While importing IPTC info,
the copyright information template 1s applied to the imported file if the Apply copyright
information template preference is set. So you can’t inadvertently import copyright
info that’s inconsistent with the template.

The export and import functions are available under the Camera > Settings sub-menu
for cameras supporting IPTC information (1D X Mark II with firmware 1.1.0 or later,
5D Mark IV and EOS R at the time of writing).

Just like with the copyright information template, imported IPTC information is automati-
cally activated in the camera.

How one can use this function? For example I have a “default” IPTC info file, one that
sets contact information in addition to the copyright related fields. I import this file to
each new IPTC capable camera, and let the copyright info template take over after that.

The Event Log

Kuuvik Capture includes a two mech- [* © Evectiog

anism to allow us to diagnose any A e R e e R T S
problems that might arise on your
computer. The first is the Event Log. It
contains the history of all errors and
warning you encountered while using
the app.

You can access it any time with the
Window > Event Log menu item.

The buttons at the bottom lets you JERA Clear ] (_Export..
clear and export the log. The event log
will be automatically displayed on new events if Show on new events is checked.




In general the events you see here are those you can do something about. Just as down-
load problems, card and disk full errors, unsupported file errors.

Reporting a Problem

Use the Help > Report a Problem menu item to contact us if you encounter any prob-
lem with Kuuvik Capture. It’s the fastest way to get in touch with us. The function cre-
ates a new email in the Mail app, with attached diagnostic information and logs.

We can fix only what we can reproduce in the lab — so with the exception of trivial
cases it’s important to tell us not just what the problem is, but also how can we make it
happen. Screen shots are also of great value. You can send them attached to this mail.
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To: support@direstudio.com ~
Ci:
Bece:

Subject: Problem Report - Kuuvik Capture

Message Size: 12 KB

— PROBLEM DESCRIPTION —
—- STEPS TO REPRODUCE —

~- DIAGNOSTIC INFORMATION ---

— LOG FILES —

console.log consolellog conscleZ.log console3.log consaled.log

console.log console?.log consclef.log  consoleS.log event.log
540 bytes 1KB 318 bytes 430 bytes
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From: Signature: | DIRE Default

eJzjcg7y0jUwSC4zdHT2LzIPzFQAAVEZKIB/OyAonxDAx 1 DhbDUouLM/DwWFQwMIQyMIEWUNpSLMNBAFQzNXQ
0tTTaBAJOAMIBSCEFDjsKqKNGODkANGegYKGuaGlppezr7sgRFpIVVSPISMRaZISIBZgwoDGAYA ThIXw==

consoleS.log
439 bytes
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The diagnostic information section
contains information about the app’s
environment: which Mac you are us-
ing; macOS and Kuuvik Capture ver-
sion numbers; as well as the result of
some basic diagnostics.

The app automatically attaches con-
sole logs from the last 10 runs. These
logs contain potential error informa-
tion.

Regarding the personal information
content of these reports, please refer
to DIRE Studio’s privacy policy:
https://www.direstudio.com/legal-
/privacy-policy/



https://www.direstudio.com/legal/privacy-policy/

Appendix
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Creating a Wi-Fi Access Point on mac0S

Imagine the following situation: you are out in the field, photographing an old castle.
You want to place the camera on a crane to photograph from a high vantage point.
The crane is higher than your longest USB cable can reach, so wireless connection
would be the most appropriate solution.

First obstacle: most Canon Wireless File Transmitters (both built-in ones and external
bricks) require an existing network to connect to in EOS Utility mode. And those that
have the option to create a network make an unbelievably slow one.

Back to our example: there’s no phone coverage (for a Personal Hotspot trick), there are
no nearby networks of any kind to connect to. You could create an ad-hoc wireless
network on your Mac, but setup is complicated and error prone (needs manual
TCP/IP configuration on both the computer an on the camera), and in the last few
versions of macOS there’s no way to create a secure Wi-Fi network. The lack of secu-
rity is a total showstopper, so this isn’t the appropriate way to make the connection
work.

There’s a neat trick, however. macOS has a built-in Internet Sharing feature that practi-
cally creates a Wi-Fi access point to share an existing network connection. The next
obstacle is that you need the network you want to share to be in the “connected” state
(think cable plugged in both to the computer and into a router). Unfortunately the
built-in loopback interface (which is always connected and provides access to the local
computer only) is not accessible from the Network preference pane in System Prefer-
ences.

The key to the trick is to make the loopback interface appear in the Network pane. Ac-
tually, it’s pretty straightforward: launch the Terminal app and copy & paste the follow-
ing two commands:

sudo networksetup -createnetworkservice Loopback 1lo0
sudo networksetup -setmanual Loopback 172.20.42.42 255.255.255.255

Enter your password to allow these modifications if macOS asks for it.
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Now your Network preference pane
should list the brand new Loopback
Service.

It’s still listed as “not connected”,
but don’t worry, that’s just a bug.

If you use multiple “network locations”,
you need to repeat the above commands
for each location. If you just use the Au-
tomatic location, then you can move to
the next step.

Go to the Sharing preference pane,
and on the list of services click Inter-
net Sharing. If the service is already

on, turn it off. Choose the Loopback service as the one you want to share your connec-

tion from. And share to computers using Wi-Fi.
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You can set up the shared Wi-Fi net-
work (the network we’ll connect the
camera to) by clicking the Wi-Fi Op-
tions button. The Wi-F1i Options
screen 1s on the bottom of this page.

The network name is your com-
puter’s name by default, but I'd rec-
ommend to enter a simple
alphanumeric name (containing no
special characters), as Canon cam-
eras have issues with displaying char-
acters outside of the simple letters
and numbers range.

All other options are the usual Wi-Fi
setup options. A few notes though.
Channels 1-11 use the 2.4 GHz band,
while 36-48 use the 5 GHz band.
Transmitters in the 70D and 6D only
operate on the 2.4 GHz band, while
the external WFT-E7 brick operates
on both. The 5 GHz band is faster
and generally has less interference
from other networks and appliances



operating in the crowded 2.4 GHz band. For security, choose WPAZ2 Personal (the other
option is None, which is unacceptable).

Once the Wi-Fi options are entered, e <)) = — Q searoh
you can start the sharing service. To LA .

do it, click the check box in front of Camputer an yeur ool ntwrscnscass ot compter —
its name in the list. macOS may ask

to turn on your Wi-Fi1 radio if it was
off, and will ask your confirmation
to start the sharing service. After the |
service has been successfully started e
you’ll see a screen similar to the one pustoeth Sharie

below:

On Service @ Internet Sharing: On

Screen Sharing Internet Sharing allows other computers to share your connection to the
Internet. Computers connected to AC power won't sleep while Internet

File Sharing Sharing is turned on.

Printer Sharing
Remote Login
Remote Management

<>

Share your connection from: Loopback

IMPORTANT: due to a macOS
bug, your selection in the share from ?
list may change to another (random)
network service. So you must check
whether it still shows the Loopback service after each start!

n o 100% &2 The Wi-F1 icon on the menu bar will change to the sharing
icon once the sharing service is ready to accept connec-
tions.

And that’s it! Your personal access point is now ready, you can connect to if from your
camera.



Please consider the environment before printing this eBook.



