-
Notifications
You must be signed in to change notification settings - Fork 3.4k
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
6.x: rename _accessible to patchable #18039
base: 6.x
Are you sure you want to change the base?
Conversation
deb5419
to
07fc240
Compare
* the accessible fields list in the entity will be used. Defaults to null. | ||
* - accessibleFields: A list of fields to allow or deny in entity accessible fields. Defaults to null | ||
* the patchable fields list in the entity will be used. Defaults to null. | ||
* - patchableFields: A list of fields to allow or deny in entity patchable fields. Defaults to null |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Wondering if we could shorten this to just patchable
. The Fields
suffix seems unnecessary.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
patchable does sound a bit like a boolean flag, though.
But I can understand that the length might be a bit cumbersome.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I like the new method names and property names. My only concern is the amount of toil this will add to the 6.x upgrade. We'll need to make sure folks are aware of the upgrade tooling more than in the past 😄
Then I will make a Youtube Video showcasing the Upgrade tool once again (since no one seems to know I showcased it in CakeFest 2023) Written docs are already present and maybe need a few touch ups in the end. |
The change in methods name would be easy to spot if one misses the rename as it would just generate an error. The array key change would be silently ignored if missed. So for those we should keep a check and show a warning. |
07fc240
to
3b2c768
Compare
Looks good 👍 |
Resolves #17375
The following Rector configs need to be created to help users upgrade to this new name:
setAccess
=>setPatchable
getAccessible
=>getPatchable
isAccessible
=>isPatchable
_accessible
=>patchable
accessibleFields
=>patchableFields