-
-
Notifications
You must be signed in to change notification settings - Fork 1.4k
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Add JsonNode.values()
to replace elements()
#4869
Milestone
Comments
Realized we probably should also change the return type, but one step at a time. EDIT: will change return value in 3.0. |
cowtowncoder
added a commit
that referenced
this issue
Dec 28, 2024
cowtowncoder
added a commit
that referenced
this issue
Dec 28, 2024
cc @pjfanning Looks like Scala module has at least one usage to update in |
cowtowncoder
changed the title
Rename
Rename Dec 31, 2024
JsonNode
method elements()
as values()
to unify naming in 3.0JsonNode
method elements()
as values()
to unify naming in 3.0; change return type
cowtowncoder
changed the title
Rename
Add Dec 31, 2024
JsonNode
method elements()
as values()
to unify naming in 3.0; change return typeJsonNode.values()
to replace elements()
cowtowncoder
added a commit
that referenced
this issue
Dec 31, 2024
cowtowncoder
added a commit
that referenced
this issue
Dec 31, 2024
cowtowncoder
added a commit
that referenced
this issue
Dec 31, 2024
cowtowncoder
added a commit
that referenced
this issue
Dec 31, 2024
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
(see https://github.com/FasterXML/jackson-future-ideas/wiki/JSTEP-6 for background)
So,
JsonNode.elements()
should be renamed asJsonNode.values()
to align naming.But to make eventual upgrading easier let's make changes to both 2.19 and 3.0 so that:
JsonNode.values()
with same signature asJsonNode.elements()
(returnIterator<JsonNode>
), make new method call existing oneJsonNode.elements()
Collection<JsonNode> values()
The text was updated successfully, but these errors were encountered: